NWDS 7.5 indirme, kurulum ve sonrası ayarlar, kullanım adımları açıklaması

buradan indirebilirsiniz veya buradan SAP NWDS 7.4 SP17 sürümünü direkt inidrebilirsiniz. Kurulumsuz: NWDS 7.5 için indirdiğiniz “NWCEIDE04P_13-80002366.ZIP” adına benzer dosyanızı ilgili dizininize bırakıp sıkıştırılmış dosyayı dışarı çıkartın. Gerekli programlar: JDK 1.8.0_31 ya da daha yüksek sürüm Çalıştırma: Dışarı çıkarttığınız dosyadan gelen eclipse klasörünün içine girip eclipse.exe dosyasını çalıştırabilirsiniz. Çalışma alanı (workspace) seçimi: Bir çalışma alanı adı belirtin. İlgili çalışma alanı adı yanında, eclipse açılırken verdiğiniz çalışma alanı adı yanında aynı alan adı ile .jdi uzantılı bir klasör oluşur. Açılma anında aşağıdaki gibi hata ile karşılaşabilirsiniz. Hata: Eclipse başladığında aşağıdaki gibi hata ile karşılarşırsanız, çözümü hatanın altındadır. [code lang=”html”] " SAP NetWeaver Developer Studio Startup Configuration You are running Developer Studio with an unsupported JVM. Click Details for more information. Click OK to continue running. You should configure a supported JVM, e.g. in eclipse.ini via -vm parameter. Reason: You have to use a JDKas a JVM instead of a JRE Details: Current JVM: Oracle Corporation JRE 1.8.0_161 java_home=C:\Program Files\Java\jre.18.0_161 Supported JVMs: JDK provided by Oracle Corpotaion: java.version 1.8.0_31 or higher JDK provided by SAP AG: java.version 1.8.0_31 or higher A JDK is not the same as a JRE. If a JDK is required, a JRE is not sufficient " [/code] Çözüm: eclipse klasörü içerisinde eclipse.ini dosyasının en yukarısına aşağıdaki komutu yazınız. [code] " -vm C:\Program Files\Java\jdk1.8.0_161\bin " [/code] Proje oluşturma: Git dopusunda proje alma: Buradaki adımlar ile yapabilirsiniz. Proje referanslar ayarlar: Proje-> Properties-> Java Built Path-> Libraries-> SAP Java EE 5 Libraries-> altında kurulumsuz bıraktığınız \eclipse\plugins dizininden gerekli olan jar dosyalarının geldiğini görebilirsiniz. Seçime bağlı Gereksinimler: JSF projesi ise Java Built Path içine Mojarra jar dosyasını eklemelisiniz. javax.faces-2.1.24.jar şeklinde dosya eklerseniz, SAP Portal sunucusunda da javax~faces~2.1.24(local.j2ee) olmaldır. SAP sunucusunda sda dosyasının olup olmadığının kontrolü için aşağıdaki menü yolunu kullanabilirsiniz. Eclipse-> Window-> Perspective-> Open Perspective-> Others…-> Deployment-> OK-> Repository Explorer Tab: SYSID-> javax~faces~2.1.24(local.j2ee) veya javax~faces~2.2.8(local.j2ee) şeklinde dosyalar bulunmalıdır. SAP Sunucu ekleme: Buradaki adımlar ile SAP sunucusu ekleme işlemini yapabilirsiniz. Yerel sunucu ekleme: Eclipse-> Window-> Preferences-> Server-> Runtime Environment-> Add-> Apache-> Apache Tomcat v8.0-> Next-> on Tomcat Server Window: Name: Apache Tomcat v8.0 Tomcat installation directory: D:\java\apis\apache-tomcat-8.0.50 JRE: Workbench default JRE or jdk1.8.0_161 Finish-> OK Eclipse-> Window-> Show View-> Servers-> right click-> New-> Server-> on Define a New Server Window: Selcet the server type: Tomcat v8.0 Server Server’s host name: localhost Server name: Tomcat v8.0 Server at localhost Server runtime environment: Apache Tomcat v8.0-> Next-> Available: MyApplicationName-> Add-> Finish Yerelde RFC bağlantıları için dizin ortamı hazırlama: This PC-> Properties-> Advanced system settings-> Environment Variables-> System Variables-> Variable: Path-> Edit…-> Add-> ;D:\java\JavaJco-> OK-> OK-> OK Yerelde çalıştırma: Eclipse-> Window-> Show View-> Servers-> Tomcat v8.0 Server at localhost [Stopped, Republished]-> right click-> Debug-> ]]>

Leave a Reply

Your email address will not be published. Required fields are marked *